Телефоны
26 января 2015, 17:10

Google объяснила причину сохранения уязвимости в "старых" версиях Android

Компания Google объяснила, почему не будет устранять уязвить в смартфонах, работающих под управлением операционной системы ниже Android 4.4. По словам Адриана Людвига - главы подразделения Google, отвечающего за безопасность в ОС Android – длина кода, затрагивающего баг, составляет 5 миллионов строк. Мало того, изменения в этом коде могут быть не безопасными. Об это Людвиг написал в сообщении в соцсети Google+.

В то же время эксперт советует всем владельцам смартфонов с операционной системой ниже Android 4.4 просто установить браузеры Chrome или Firefox, которые бесплатны для загрузки с Google Play Store. Два этих браузера имеют собственные контент-рендереры и часто обновляются. Если пользователи будут использовать последние версии этих браузеров, то смогут защитить себя от текущих и будущих проблем.

Напомним, что уязвимость касается примерно 939 миллионов мобильных устройств под управлением Android. Проблема заключается в компоненте WebView, который используется в версиях Android вплоть до 4.4 KitKat при рендеринге веб-контента.

Источник новости: Google